MERCEDES-Benz Anciennes


Mercedes W108

Echanges autour des Mercedes-Benz de la seconde moitié du XXe siècle - Entretien et Maintenance

Vous n'êtes pas identifié(e).

#1 11-08-2020 20:49:17

Morbik
Membre
Inscription : 19-02-2018
Messages : 143

W124 300TE - Test de l'EHA

Bonjour a tous,

L’OBD-0 remonte un défaut qui correspondrait pour mon modèle à un « courant traversant l’EHA incorrect» (rapport cyclique 90%).


J’ai fabriqué un câble pour placer un amperemetre en série avec l’EHA et pouvoir lire le courant le traversant tout en étant au volant. On semble distinguer une bande légèrement colorée sur un des deux câbles de l’EHA, l’autre étant entièrement noir. Selon les standards appliqués en électronique, celui avec la bande devrait être le +



Si c’est bien le cas, et si mes yeux ne me font pas défaut, voilà les valeurs que j’ai relevées en faisant un test sur route :

Contact mis, moteur arrêté : -0,4mA
Moteur au ralenti à froid : -0,4mA
Moteur au ralenti à chaud : -0,4mA
En roulant : vitesse stable, accélération, pleine charge : -0,4mA
Décéleration (pas de gaz) : 1,1mA

Bref, quelques soient les conditions j’ai un courant de -0,4mA, sauf dans les phases qui correspondent à la coupure d’injection en deceleration où j’ai 1,1mA.



J’ai trouvé des valeurs de courant « quand tout va bien » ici (bas de page) : https://k-jet.biz/tests/
Je ne sais pas si ça s’applique à tous les types d’injection jetronic.



Avant d'aller plus loin sur le test de cet EHA, j'ai quelques questions pour comprendre un peu mieux ce que je viens de mesurer :

- Le courant est-il proportionnel à l’ouverture de la vanne ?
- Ce courant dépend il du réglage de la vis se trouvant sur l’EHA qui joue sur le débit d’essence nominal ?
- Comme l’EHA est un actionneur, un courant non conforme peut aussi être la faute de ce qui le commande non ? (en l’occurrence le calculateur)



Clément


W124 300te, 1992

Hors ligne

#2 11-08-2020 22:49:54

ttdi75
Membre
Inscription : 30-08-2015
Messages : 582

Re : W124 300TE - Test de l'EHA

Bonjour, as tu lu les discussions concernant les EHA sur le forum ? (dont la mienne "ratés moteurs") c'est assez instructif. Les chiffres qui sont indiqués dans ton lien ne sont sans doute pas valable pour toutes les KE (en tous cas pour les pressions c'est le cas). L'EHA module la pression entre les chambres basses et hautes du distributeur, il agit donc indépendamment du plongeur du distributeur. Normalement au ralenti a chaud il doit permettre un écart de 0.4 bar entre chambres hautes/basses. Pour tes mesures, sur mon auto (420 SL) les mesures attendues sont entre 3 et 3,5ma au ralenti à chaud. Je ne pense pas que le courant dépende du réglage de la vis (que je te déconseille de bidouiller). As tu roulé EHA débranché (voiture chaude) ? ta voiture fonctionne t'elle normalement dans ce cas ?

Chris77 connait bien le fonctionnement de l'EHA, Corail pourra aussi t'aider, c'est bien d'avoir commencé par un diagnostique OBD 0 !


W107  420sl

Hors ligne

#3 12-08-2020 06:06:17

Corail
Administrateur
Lieu : Hérault
Inscription : 06-02-2008
Messages : 9 752
Site Web

Re : W124 300TE - Test de l'EHA

OUI .. il faut écouter l'OBD.


Achat d'occasion: 220SEb/C (1991) 230TE (2005) 280CE (2005), 320CE (2012),
Achetés neufs:     300D (aout 1980) & 300TD (novembre 84)

En ligne

#4 12-08-2020 23:26:28

Morbik
Membre
Inscription : 19-02-2018
Messages : 143

Re : W124 300TE - Test de l'EHA

Effectivement, le topic lancé par Chris77  m’a bien aidé https://www.mercedes-anciennes.fr/forum … p?id=11884
Je n’avais pas vu le tien, beaucoup d'informations également.


As tu roulé EHA débranché (voiture chaude) ?

J’avais prévu de faire le test quand j'ai fait les mesures, et sur le moment je n’y ai plus pensé. Dommage, alors que j’avais la possibilité de le débrancher en roulant directement depuis l’habitacle…

Si j’ai bien compris, sans courant dans l’actionneur (donc débranché), la vanne reste à une position nominale, qui est (presque) fermée. La voiture est censée pouvoir rouler correctement dans ces conditions (mais pas de coupure a la deceleration, d’enrichissement en charge, etc ...)

Je ferai le test à la prochaine sortie (et pourquoi pas carrément calculateur débranché également), je vous tiens au courant.


Quoi qu’il en soit, je suppose que le courant devrait changer pour l’enrichissement à pleine charge notamment. Donc il y a sûrement quelque chose qui ne va pas dans tout ça...


W124 300te, 1992

Hors ligne

#5 13-08-2020 12:38:31

chris77
Membre
Lieu : Seine et Marne
Inscription : 18-11-2013
Messages : 134

Re : W124 300TE - Test de l'EHA

En effet les intensités dans l'EHA sont incorrectes. Merci l'OBD ! Tu devrais mesurer plus de 15 mA en accélération, et 60 mA en coupure à la décélération.

Je te suggère de mesurer la résistance de l'EHA : cible 19.5 ohm + ou - 1.5 ohm. Si différente, envisage de remplacer l'EHA (dispo chez BOSCH mais très cher...).

Si elle est correcte, contrôle les deux fils qui relient l'EHA à la broche du calculateur KE (pin 10 et 12). Vérifie que les deux fils sont isolés l'un par rapport à l'autre, et isolés par rapport à la masse, et contrôle leur absence de résistance entre connecteur KE et prise EHA.

Dernière modification par chris77 (13-08-2020 12:39:46)


Coupé SLK R170 200 atmo

Hors ligne

#6 19-08-2020 10:12:50

Morbik
Membre
Inscription : 19-02-2018
Messages : 143

Re : W124 300TE - Test de l'EHA

Impec merci pour les infos Chris !

Test fait lors de mon dernier trajet vers les Carpates Roumaines :

Résistance de l'EHA : 20,7 Ohm -> OK, c'est dans la tolérance

Conduite avec EHA débranché :
- Même difficulté pour démarrer à chaud (pas de surprise de ce côté là)
- En condition normale (EHA branché) quand je lève le pied, le frein moteur devient un peu plus fort après environ une seconde. Je suppose que c'est la coupure d'injection (qui ne se fait pas instantanément, donc). Avec l'EHA débranché, je n'observe plus cela. Donc je suppose que EHA branché, la coupure d'injection fonctionne.
- Peut être (mais difficile d'en être sur) un peu moins de puissance a pleine charge. Ce qui laisse penser qu'en temps normal il y aurait bien un enrichissement à pleine charge.
- En dehors de ça, je n'ai noté aucune différence sur le fonctionnement de la voiture.

Je n'ai pas eu le temps de tester la liaison entre l'EHA et le calculateur. La voiture a reçu une installation GPL, les fils de l'EHA ont été dirigés vers le calculateur GPL également. J'ose espérer que ça a été fait correctement et qu'il est toujours bien branché au calculateur KE également.
Je vous tiens au courant des que j'ai testé tout ça, mais je ne serais pas surpris que le problème vienne de là...

Dernière modification par Morbik (19-08-2020 10:13:46)


W124 300te, 1992

Hors ligne

#7 17-09-2020 11:36:55

Morbik
Membre
Inscription : 19-02-2018
Messages : 143

Re : W124 300TE - Test de l'EHA

De retour apres 3 semaines de vacances loin de mon carrosse


Test de la connexion de l'EHA au calculateur :

Fil marron/noir (borne 10) -> résistance 1.3 Ω, isolé par rapport a la masse
Fil noir (borne 12) -> 0.3 Ω, isolé par rapport a la masse

Les deux fils sont bien isolés entre eux.

Est-ce que l'on peut considérer la resistance de 1.3 Ω du fil marron/noir acceptable ? Je pense qu'elle reste negligeable par rapport aux 19,5 Ω de l'EHA. Si oui, la connexion entre l'EHA et la calculateur est OK.



Au passage j'ai re mesuré la resistance aux bornes de l'EHA, à froid cette fois-ci : 19,2 Ω (et 20,7 Ω à chaud)
Aussi, pendant les vacances j'ai recuperé un EHA que j'avais en stock. Il n'est pas neuf et j'ai aucune idée de son état. En tous cas la résistance a ses bornes est OK.

Donc : si on considère que la connexion est ok, le problème viendrait de l'EHA lui même (ou du calculateur, ce qui ne me rendrait pas jouasse neutral ). Est-ce qu'il y a d'autres points à verifier avant de tester avec un autre EHA ?


W124 300te, 1992

Hors ligne

#8 17-09-2020 13:51:23

Corail
Administrateur
Lieu : Hérault
Inscription : 06-02-2008
Messages : 9 752
Site Web

Re : W124 300TE - Test de l'EHA

Est-ce que l'on peut considérer la résistance de 1.3 Ω du fil marron/noir acceptable ? Je pense qu'elle reste négligeable par rapport aux 19,5 Ω de l'EHA.

En fait, c'est le courant circulant dans le fil qui importe, il détermine une chute de tension .. qui perturbera l'EHA si cette chute est importante.



EHA:   c'est une sorte d'électrovanne.
Existent deux comportements: statique & dynamique.

Statique:      c'est l'état de ce que tu mesures à l'Ohmmètre,
                   c'est une réponse en courant telle que   U = RI
Dynamique:  c'est l'état de ce que tu peux mesurer en fonctionnement (d'où le terme de dynamique)   
                   la réponse en courant n'est plus U=RI    mais U = RI + fcem   (fcem = effet de self s'opposant au courant, généré par la bobine)

Si l'EHA est grippé (ou coince) ses caractéristiques 'statiques' n'évoluent pas mais ses caractéristiques 'dynamiques' qui ne correspondent plus au modèle.
Cet EHA est commandé non pas en tension continue-continue mais en tension continue-discontinue (interrompue cycliquement): ce cycle c'est le PWM (Modulation par largeur d'Impulsion).
   Il est possible de mesurer la tension générée par la bobine de l'EHA (mesure de cette fcem) dans les 'creux' de modulation de la PWM, instants où le calculateur n'envoie pas de tension.
   C'est ainsi que j'avais asservi la vitesse de rotation de moteur de locomotive modèle réduit,  je ne sais pas si le calculateur pratique ce genre de mesure (ce qui lui permettrait de connaitre l'état de fonctionnement de son EHA)

=> Effectivement, remplacer cet EHA qui est bon en statique par un autre apparemment tout aussi 'bon' peut être une solution.

Dernière modification par Corail (17-09-2020 18:24:40)


Achat d'occasion: 220SEb/C (1991) 230TE (2005) 280CE (2005), 320CE (2012),
Achetés neufs:     300D (aout 1980) & 300TD (novembre 84)

En ligne

#9 21-09-2020 14:45:14

Morbik
Membre
Inscription : 19-02-2018
Messages : 143

Re : W124 300TE - Test de l'EHA

Merci pour les precisions Corail.

Ce matin j'ai monté l'autre EHA :
- Je n'ai pas noté de changement dans le fonctionnement du moteur
- L'OBD me remonte toujours un code 90% (courant EHA improbable)
- Le courant traversant l'EHA sont les mêmes qu'avec le précédent EHA -> 1,1mA en deceleration, -0,4mA dans tous les autres cas (y compris avec contact, moteur arreté)

Donc soit les deux EHA sont grippés/defaillants exactement de la meme façon, ce qui me semble peu probable, soit la cause de ces courants incorrects se trouve ailleurs.

Pour la resistance des fils, la somme des deux ferait une chute de tension d'environ 8% de la tension de commande aux bornes de l'EHA. Et je ne saurais pas du tout dire si c'est negligeable ou pas neutral
Quels autres composants pouraient etre impliqués dans ces courants anormaux ?


W124 300te, 1992

Hors ligne

#10 21-09-2020 17:58:45

Corail
Administrateur
Lieu : Hérault
Inscription : 06-02-2008
Messages : 9 752
Site Web

Re : W124 300TE - Test de l'EHA

ce qui tend à penser que le comportement de l'EHA serait une conséquence d'un cause à identifier.


Achat d'occasion: 220SEb/C (1991) 230TE (2005) 280CE (2005), 320CE (2012),
Achetés neufs:     300D (aout 1980) & 300TD (novembre 84)

En ligne

#11 22-09-2020 07:16:54

chris77
Membre
Lieu : Seine et Marne
Inscription : 18-11-2013
Messages : 134

Re : W124 300TE - Test de l'EHA

L'EHA est alimenté par des impulsions modulées. Question pour Corail : si les fils d'alimentation ont été modifiés, notamment rallongés, cela pourrait avoir modifié l'impédance de la liaison calculateur-EHA, donc affaiblir le courant le traversant ?


Coupé SLK R170 200 atmo

Hors ligne

#12 22-09-2020 10:46:36

Corail
Administrateur
Lieu : Hérault
Inscription : 06-02-2008
Messages : 9 752
Site Web

Re : W124 300TE - Test de l'EHA

PWM: Modulation par largeur d'impulsions, la fréquence est constante (= n'est pas modifiée).


L'impédance d'une ligne de transmission est indépendante de sa longueur.
   Une telle ligne est souvent bifilaire (twistée ou pas) elle est alors symétrique (mais peut être coaxiale, auquel cas elle est dissymétrique).
   Ce qui détermine son impédance: 
         - sa capacité répartie (= capacité d'un point de la ligne avec son vis-à-vis) càd les surfaces réciproques de leur diamètre, l'isolant, la distance entre lignes,
         - sa self répartie (= self entre deux points consécutifs),
                     le point a à être compris dans son contexte mathématique (c'est un point 'virtuel')
         - sa résistance répartie (= résistance entre deux points, isolation entre deux points) .. toutes deux négligeables,
                   Ces constantes (C, L, R) sont dites réparties ... par opposition aux constantes discrètes (= celles que l'on peut mesurer)

    Reformulation en une image:      mini_Z.png     cette image 'représente' un point (un seul)  ... une ligne est une succession ininterrompue de points ..
  => allonger une telle ligne par des composants différents va forcément modifier son impédance mais ...

       mais le mode de propagation du signal est déterminée majoritairement par sa fréquence:  à 100Hz, l'impédance n'affecte pas la conduction du courant,
 


Que se passe-t-il en appliquant une tension continue à Gauche de cette image ??
      - L et R s'oppose à la charge de C   (dx est la transcription mathématique signifiant un lien avec la position)
      - C met un certain temps à se charger et une fois chargé  .. la tension est présente à Droite de l'image
               Cette représentation permet d'imaginer la propagation de point en point ... sur une ligne infinie, traduite par dx
      => au bout de cette ligne arrive une impulsion (celle de la charge de la capa initiale): une énergie a été propagée .. sans circulation de courant continu.
            C'est un mode de propagation différent de celui de la conduction ci-dessus: le mode de propagation est liée à la fréquence.


Achat d'occasion: 220SEb/C (1991) 230TE (2005) 280CE (2005), 320CE (2012),
Achetés neufs:     300D (aout 1980) & 300TD (novembre 84)

En ligne

Pied de page des forums

Propulsé par FluxBB